[Firefox] 〇〇と互換性がないためアドオンをインストールできません の対処法

   2015/09/29

FIrefoxのアドオンKeysnailをインストールするときに

33.03と互換性がないためアドオンをインストールできません

と出てインストールできなかったので場当たり的対処したときのメモ。

マイナーディストリなんで更新が遅いじゃ・・・。

むろん互換性が無いものを無理やり入れる形になるので、なにか問題が発生しても知りません。

手順

addonを右クリックで保存しxpiファイルを手に入れる

以下keysnail.xpiの場合

tmpディレクトリにkeysnail.xpiを展開

 install.rdfを編集する

 minVersionを適当な値に書き換える

 ディレクトリ内に移動してから圧縮

移動せずにtmpディレクトリまるごと圧縮するとインストールできません

圧縮されたkeysnail.xpiをfirefoxにドラッグ&ドロップでインストール

コメントを残す